Я установил новое ядро ​​5.15.0 на свой Linux Mint 19.3 (Ubuntu 18.04) с помощью https: //github.com/pimlie/ubuntu-mainline-kernel.sh.

Все работало нормально, но не для заголовков ядра, что дало мне ошибку установки из-за ожидаемой версии LIBC, которая должна быть> = 2.34, вместо Ubuntu 18.04, которая поставляется с 2.27.

Можно ли решить эту проблему без ущерба для стабильности системы?

Спасибо огромное!

0
Antonio Petricca 5 Ноя 2021 в 18:12

2 ответа

Лучший ответ

Проблема решилась компиляцией нового ядра самостоятельно.

1
Antonio Petricca 7 Ноя 2021 в 21:15

Вы можете легко установить новое ядро ​​с его заголовками из основной ветки.

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

Используйте mainline --list для вывода списка доступных ядер (см. mainline --help)

Чтобы установить версию ядра 5.15, используйте:

mainline --install 5.15.0

Приведенная выше команда установит ядро ​​​​и пакет linux-headers.

Графический интерфейс можно запустить через:

mainline-gtk
1
GAD3R 5 Ноя 2021 в 18:38
К сожалению, я получил ту же ошибку в заголовках и LIBC.
 – 
Antonio Petricca
5 Ноя 2021 в 19:01