Я пытался установить определенное программное обеспечение в свой Kali Linux и использовал в процессе команду aptitude. Однако во время его использования мне было предложено то, что единственное, что я помню о нем, это действие на 17 ГБ.

Я не был сосредоточен, поэтому продолжал отвечать «да», пока не перезагрузился и не обнаружил, что графический интерфейс недоступен. Только терминал для работы. Пытался использовать tasksel для установки среды рабочего стола, но возникла ошибка. После некоторых исследований я понял, что на самом деле потерял 17 ГБ данных и не могу ничего установить, потому что у меня отсутствуют все зависимости для любого программного обеспечения или команды, которую я пытаюсь установить.

Я добавил эти репозитории

  • repo.steampowered.com/steam
  • repo.skype.com/deb
  • кали.скачать/кали

Есть ли способ установить все основные зависимости сразу (apt dist-upgrade тоже не работает, а также отображает несколько отсутствующих зависимостей) или вернуть систему в более раннее состояние? Стоит отметить, что я нашел большую часть программного обеспечения /var/cache/apt/archives, но не могу установить их по той же причине. Отсутствующие зависимости

[Редактировать]

Этот пост почти объясняет мою текущую ситуацию: https://askubuntu.com/questions/ 716915/dpkg-error-processing-packages-cannot-complete-install-desktop-gui-from-termina Единственная разница в том, что у меня отображаются ошибки почти для каждого пакета в моем Kali (не только для некоторых программ, таких как сообщение), а источник проблемы - результат неправильного использования aptitude

Это вывод любого apt либо при попытке upgrade , --fix-broken install или dist-upgrade, либо при установке определенной команды: (вывод еще больше, но не может быть включен в этот Почта.)

Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 airgeddon : Depends: aircrack-ng but it is not installed
 altdns : Depends: python3-termcolor but it is not installed
 androguard : Depends: python3-click but it is not installed
              Depends: python3-colorama but it is not installed
              Depends: python3-ipython but it is not installed
              Depends: python3-networkx but it is not installed
              Depends: python3-pydot but it is not installed
              Recommends: python3-pyperclip but it is not installed
 android-sdk : Depends: default-jre but it is not installed
 arjun : Depends: python3-dicttoxml but it is not installed
 awscli : Depends: python3-pyasn1 but it is not installed
          Depends: python3-colorama but it is not installed
          Depends: python3-docutils but it is not installed
 beef-xss : Depends: ruby-ansi but it is not installed
            Depends: ruby-async-dns but it is not installed
            Depends: ruby-em-websocket (>= 0.3.6) but it is not installed
            Depends: ruby-erubis but it is not installed
            Depends: ruby-espeak but it is not installed
            Depends: ruby-execjs but it is not installed
            Depends: ruby-maxmind-db but it is not installed
            Depends: ruby-mime-types but it is not installed
            Depends: ruby-msfrpc-client but it is not installed
            Depends: ruby-otr-activerecord but it is not installed
            Depends: ruby-parseconfig but it is not installed
            Depends: ruby-qr4r but it is not installed
            Depends: ruby-rack (>= 1.4.1) but it is not installed
            Depends: ruby-rack-protection but it is not installed
            Depends: ruby-rubydns (>= 0.7.0) but it is not installed
            Depends: ruby-rushover but it is not installed
            Depends: ruby-sinatra (>= 1.4.2) but it is not installed
            Depends: ruby-slack-notifier but it is not installed
            Depends: ruby-sqlite3 but it is not installed
            Depends: ruby-term-ansicolor but it is not installed
            Depends: ruby-twitter but it is not installed
            Depends: ruby-uglifier (>= 2.2.1) but it is not installed
            Depends: ruby-zip (>= 1.0.0) but it is not installed
            Depends: thin but it is not installed
            Recommends: geoipupdate but it is not installed
 bettercap : Depends: libnetfilter-queue1 (>= 1.0.0) but it is not installed
 brutespray : Depends: medusa but it is not installed
              Recommends: nmap but it is not installed
 changeme : Depends: python3-psycopg2 but it is not installed
            Depends: python3-pysnmp4 but it is not installed
            Depends: python3-redis but it is not installed
            Depends: python3-selenium but it is not installed
            Depends: python3-shodan but it is not installed
            Depends: python3-sqlalchemy but it is not installed
            Depends: python3-tabulate but it is not installed
 cherrytree : Depends: libfmt7 (>= 7.1.3+ds1) but it is not installed
              Depends: libgtksourceviewmm-3.0-0v5 (>= 3.18.0) but it is not installed
              Depends: libxml++2.6-2v5 (>= 2.40.0) but it is not installed
 commix : Depends: unicorn-magic (>= 3.12) but it is not installed
 cpp-11 : Depends: gcc-11-base (= 11.2.0-10) but 11.2.0-9 is installed
 crackmapexec : Depends: python3-impacket but it is not installed
                Depends: python3-pywerview but it is not installed
                Depends: python3-aioconsole but it is not installed
                Depends: python3-lsassy but it is not installed
                Depends: python3-msgpack but it is not installed
                Depends: python3-neo4j but it is not installed
                Depends: python3-pylnk but it is not installed
                Depends: python3-pypsrp but it is not installed
                Depends: python3-requests-ntlm but it is not installed
                Depends: python3-termcolor but it is not installed
                Depends: python3-terminaltables but it is not installed
                Depends: python3-xmltodict but it is not installed
 crowbar : Depends: freerdp2-x11 but it is not installed
 dirsearch : Depends: python3-colorama but it is not installed
 dnsgen : Depends: python3-click but it is not installed
 dumpsterdiver : Depends: python3-colorama but it is not installed
                 Depends: python3-termcolor but it is not installed
 eaphammer : Depends: python3-flask-socketio but it is not installed
             Depends: python3-scapy but it is not installed
             Depends: python3-tqdm but it is not installed
             Depends: responder but it is not installed
             Depends: seclists but it is not installed
 emailharvester : Depends: python3-colorama but it is not installed
                  Depends: python3-termcolor but it is not installed
 ettercap-common : Depends: ethtool but it is not installed
                   Depends: libluajit-5.1-2 (>= 2.0.4+dfsg) but it is not installed
                   Depends: libnet1 (>= 1.1.6) but it is not installed
 eyewitness : Depends: python3-selenium but it is not installed
              Depends: xvfb
 finalrecon : Depends: python3-ipwhois but it is not installed
              Depends: python3-dnslib but it is not installed
              Depends: python3-aiohttp but it is not installed
              Depends: python3-psycopg2 but it is not installed
 firebird3.0-server-core : Depends: firebird3.0-common (= 3.0.7.33374.ds4-2) but 3.0.7.33374.ds4-3 is installed
                           Depends: firebird3.0-common-doc (= 3.0.7.33374.ds4-2) but 3.0.7.33374.ds4-3 is installed
                           Recommends: firebird3.0-utils but it is not installed
 firewalk : Depends: libnet1 (>= 1.1.2.1) but it is not installed
 freeradius : Depends: libct4 (>= 0.64) but it is not installed
              Recommends: freeradius-utils but it is not installed
 freeradius-wpe : Depends: libct4 (>= 0.64) but it is not installed
 g++-11 : Depends: gcc-11-base (= 11.2.0-10) but 11.2.0-9 is installed
 gcc-11 : Depends: gcc-11-base (= 11.2.0-10) but 11.2.0-9 is installed
 gcc-11-base : Breaks: gcc-11-base:i386 (!= 11.2.0-9) but 11.2.0-10 is installed
 gcc-11-base:i386 : Breaks: gcc-11-base (!= 11.2.0-10) but 11.2.0-9 is installed
 gnuradio : Depends: python3-click but it is not installed
            Depends: python3-click-plugins but it is not installed
            Depends: python3-mako but it is not installed
            Depends: python3-numpy but it is not installed
            Depends: python3-pyqtgraph but it is not installed
            Depends: liblog4cpp5v5 (>= 1.1.3) but it is not installed
            Recommends: python3-networkx but it is not installed
            Recommends: python3-scipy but it is not installed
 gqrx-sdr : Depends: liblog4cpp5v5 (>= 1.1.3) but it is not installed
 gr-air-modes : Depends: liblog4cpp5v5 (>= 1.1.3) but it is not installed
                Recommends: python3-numpy but it is not installed
                Recommends: python3-scipy but it is not installed
 gr-iqbal : Depends: liblog4cpp5v5 (>= 1.1.3) but it is not installed
 gr-osmosdr : Depends: liblog4cpp5v5 (>= 1.1.3) but it is not installed
              Recommends: gr-fosphor but it is not installed
 grokevt : Depends: reglookup but it is not installed
 gstreamer1.0-plugins-bad : Depends: libaom0 (>= 1.0.0) but it is not installed
                            Depends: libdc1394-25 (>= 2.2.6) but it is not installed
                            Depends: libdca0 (>= 0.0.5) but it is not installed
                            Depends: libdvdnav4 (>= 4.1.3) but it is not installed
                            Depends: libfaad2 (>= 2.7) but it is not installed
                            Depends: libfluidsynth2 (>= 2.0.5) but it is not installed
                            Depends: libkate1 (>= 0.4.1) but it is not installed
                            Depends: libltc11 (>= 1.2.0) but it is not installed
                            Depends: libmjpegutils-2.1-0 but it is not installed
                            Depends: libmms0 (>= 0.4) but it is not installed
                            Depends: libmodplug1 (>= 1:0.8.8.5) but it is not installed
                            Depends: libmpcdec6 (>= 1:0.1~r435) but it is not installed
                            Depends: libmpeg2encpp-2.1-0 but it is not installed
                            Depends: libmplex2-2.1-0 but it is not installed
                            Depends: libnice10 (>= 0.1.14) but it is not installed
                            Depends: libofa0 (>= 0.9.3) but it is not installed
                            Depends: libopenal1 (>= 1.14) but it is not installed
                            Depends: libopenni2-0 (>= 2.2.0.33+dfsg) but it is not installed
                            Depends: libspandsp2 (>= 0.0.6~pre18) but it is not installed
                            Depends: libvo-aacenc0 (>= 0.1.3) but it is not installed
                            Depends: libvo-amrwbenc0 (>= 0.1.3) but it is not installed
                            Depends: libwildmidi2 (>= 0.2.3) but it is not installed
 gstreamer1.0-plugins-good : Breaks: gstreamer1.0-plugins-good:i386 (!= 1.18.5-1) but 1.18.5-1+b1 is installed
 gstreamer1.0-plugins-good:i386 : Breaks: gstreamer1.0-plugins-good (!= 1.18.5-1+b1) but 1.18.5-1 is installed
 gvm : Depends: xsltproc
       Recommends: greenbone-security-assistant (>= 21.4.2) but it is not installed
       Recommends: gvm-tools but it is not installed
 gvmd-common : Depends: xsltproc
 hcxtools : Depends: ieee-data but it is not installed
 hosthunter : Depends: python3-selenium but it is not installed
 hydra : Depends: libfreerdp2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) but it is not installed
         Depends: libmemcached11 but it is not installed
         Depends: libsvn1 (>= 1.10) but it is not installed
         Depends: libwinpr2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) but it is not installed
 ibombshell : Depends: powershell but it is not installed
              Depends: python3-termcolor but it is not installed
 intel-media-va-driver : Breaks: intel-media-va-driver:i386 (!= 21.3.4+dfsg1-1) but 21.4.1+dfsg1-1 is installed
 intel-media-va-driver:i386 : Breaks: intel-media-va-driver (!= 21.4.1+dfsg1-1) but 21.3.4+dfsg1-1 is installed
 ipv6-toolkit : Depends: ieee-data but it is not installed
 ivre : Depends: python3-bottle but it is not installed
        Depends: python3-future but it is not installed
        Depends: python3-mysqldb but it is not installed
        Depends: python3-pil but it is not installed
        Depends: python3-psycopg2 but it is not installed
        Depends: python3-sqlalchemy but it is not installed
        Recommends: nmap but it is not installed
 jd-gui : Depends: default-jre but it is not installed
          Depends: jarwrapper but it is not installed
 kali-linux-arm : Depends: aircrack-ng but it is not installed
                  Depends: cewl but it is not installed
                  Depends: crunch but it is not installed
                  Depends: dnsrecon but it is not installed
                  Depends: john but it is not installed
                  Depends: medusa but it is not installed
                  Depends: mfoc but it is not installed
                  Depends: ncrack but it is not installed
                  Depends: nmap but it is not installed
                  Depends: passing-the-hash but it is not installed
                  Depends: windows-binaries but it is not installed
                  Depends: winexe but it is not installed
                  Depends: wpscan but it is not installed
                  Depends: cgpt
                  Depends: ethtool but it is not installed
                  Depends: libnfc-bin but it is not installed
                  Depends: vboot-utils
                  Depends: vboot-kernel-utils but it is not installed
 kali-linux-default : Depends: autopsy but it is not installed
                      Depends: cutycapt but it is not installed
                      Depends: dirbuster but it is not installed
                      Depends: faraday but it is not installed
                      Depends: fern-wifi-cracker but it is not installed
                      Depends: guymager but it is not installed
                      Depends: king-phisher but it is not installed
                      Depends: legion but it is not installed
                      Depends: ophcrack but it is not installed
                      Depends: ophcrack-cli but it is not installed
                      Depends: gparted but it is not installed
                      Depends: rdesktop but it is not installed
                      Depends: recordmydesktop but it is not installed
                      Depends: sqlitebrowser but it is not installed
 kali-linux-headless : Depends: aircrack-ng but it is not installed
                       Depends: arp-scan but it is not installed
                       Depends: arping but it is not installed or
                                iputils-arping
                       Depends: bulk-extractor but it is not installed
                       Depends: bully but it is not installed
                       Depends: cadaver but it is not installed
                       Depends: cewl but it is not installed
                       Depends: chntpw but it is not installed
                       Depends: creddump7 but it is not installed
                       Depends: crunch but it is not installed
                       Depends: cryptcat but it is not installed
                       Depends: davtest but it is not installed
                       Depends: dbd but it is not installed
                       Depends: dirb but it is not installed
                       Depends: dmitry but it is not installed
                       Depends: dns2tcp but it is not installed
                       Depends: dnschef but it is not installed
                       Depends: dnsenum but it is not installed
                       Depends: dnsrecon but it is not installed
                       Depends: enum4linux but it is not installed
                       Depends: exe2hexbat but it is not installed
                       Depends: ffuf but it is not installed
                       Depends: fierce but it is not installed
                       Depends: fping but it is not installed
                       Depends: gpp-decrypt but it is not installed
                       Depends: hash-identifier but it is not installed
                       Depends: hashcat but it is not installed
                       Depends: hashcat-utils but it is not installed
                       Depends: hashid but it is not installed
                       Depends: hping3 but it is not installed
                       Depends: i2c-tools but it is not installed
                       Depends: ike-scan but it is not installed
                       Depends: impacket-scripts but it is not installed
                       Depends: inetsim but it is not installed
                       Depends: iodine but it is not installed
                       Depends: john but it is not installed
                       Depends: kismet but it is not installed
                       Depends: lbd but it is not installed
                       Depends: macchanger but it is not installed
                       Depends: magicrescue but it is not installed
                       Depends: maltego but it is not installed
                       Depends: maskprocessor but it is not installed
                       Depends: masscan but it is not installed
                       Depends: mimikatz but it is not installed
                       Depends: mitmproxy but it is not installed
                       Depends: msfpc but it is not installed
                       Depends: nasm but it is not installed
                       Depends: nbtscan but it is not installed
                       Depends: ncrack but it is not installed
                       Depends: ncurses-hexedit but it is not installed
                       Depends: netdiscover but it is not installed
                       Depends: netsed but it is not installed
                       Depends: nikto but it is not installed
                       Depends: nmap but it is not installed
                       Depends: onesixtyone but it is not installed
                       Depends: passing-the-hash but it is not installed
                       Depends: patator but it is not installed
                       Depends: pdf-parser but it is not installed
                       Depends: pdfid but it is not installed
                       Depends: pipal but it is not installed
                       Depends: pixiewps but it is not installed
                       Depends: powersploit but it is not installed
                       Depends: proxytunnel but it is not installed
                       Depends: ptunnel but it is not installed
                       Depends: python3-impacket but it is not installed

Это вывод apt list --upgradable (опять же частичный вывод):

afl++-doc/kali-rolling,kali-rolling 3.14c-2 all [upgradable from: 2.68c-1]
afl++/kali-rolling 3.14c-2 amd64 [upgradable from: 2.68c-1+b1]
amass-common/kali-rolling,kali-rolling 3.15.0-0kali1 all [upgradable from: 3.14.1-0kali1]
amass/kali-rolling 3.15.0-0kali1 amd64 [upgradable from: 3.14.1-0kali1]
apache2-bin/kali-rolling 2.4.51-2 amd64 [upgradable from: 2.4.51-1]
apache2-data/kali-rolling,kali-rolling 2.4.51-2 all [upgradable from: 2.4.51-1]
apache2-utils/kali-rolling 2.4.51-2 amd64 [upgradable from: 2.4.51-1]
apache2/kali-rolling 2.4.51-2 amd64 [upgradable from: 2.4.51-1]
apt/kali-rolling 2.3.11 amd64 [upgradable from: 2.3.9]
at-spi2-core/kali-rolling 2.42.0-2 amd64 [upgradable from: 2.42.0-1]
awscli/kali-rolling,kali-rolling 1.21.9-1 all [upgradable from: 1.20.53-1]
bash-completion/kali-rolling,kali-rolling 1:2.11-5 all [upgradable from: 1:2.11-4]
bash/kali-rolling 5.1-3.1 amd64 [upgradable from: 5.1-3+b2]
binutils-mingw-w64-i686/kali-rolling 2.37-7+9 amd64 [upgradable from: 2.35.2-2+8.11+b3]
binutils-mingw-w64-x86-64/kali-rolling 2.37-7+9 amd64 [upgradable from: 2.35.2-2+8.11+b3]
bsdextrautils/kali-rolling 2.37.2-4 amd64 [upgradable from: 2.37.2-3]
bsdutils/kali-rolling 1:2.37.2-4 amd64 [upgradable from: 1:2.37.2-3]
capstone-tool/kali-rolling 4.0.2-3+b1 amd64 [upgradable from: 4.0.2-3]
cherrytree/kali-rolling 0.99.43+dfsg-1 amd64 [upgradable from: 0.99.41+dfsg-1]
cpp-10/kali-rolling 10.3.0-12 amd64 [upgradable from: 10.3.0-11]
crackmapexec/kali-rolling,kali-rolling 5.1.7-0kali2 all [upgradable from: 5.1.7-0kali1]
cryptsetup-bin/kali-rolling 2:2.4.2-1 amd64 [upgradable from: 2:2.4.1-1]
cryptsetup-initramfs/kali-rolling,kali-rolling 2:2.4.2-1 all [upgradable from: 2:2.4.1-1]
cryptsetup/kali-rolling 2:2.4.2-1 amd64 [upgradable from: 2:2.4.1-1]
dislocker/kali-rolling 0.7.3-2+b1 amd64 [upgradable from: 0.7.3-2]
dnsmasq-base/kali-rolling 2.86-1.1 amd64 [upgradable from: 2.85-1]
dnsmasq/kali-rolling,kali-rolling 2.86-1.1 all [upgradable from: 2.85-1]
exfatprogs/kali-rolling 1.1.3-1 amd64 [upgradable from: 1.1.2-2]
exploitdb-bin-sploits/kali-rolling,kali-rolling 20211123-0kali1 all [upgradable from: 20210828-0kali1]
exploitdb-papers/kali-rolling,kali-rolling 20211117-0kali1 all [upgradable from: 20210826-0kali1]
exploitdb/kali-rolling,kali-rolling 20211118-0kali1 all [upgradable from: 20211016-0kali1]
eyewitness/kali-rolling 20211110.1-0kali1 amd64 [upgradable from: 20211018.1-0kali1]
fdisk/kali-rolling 2.37.2-4 amd64 [upgradable from: 2.37.2-3]
feroxbuster/kali-rolling 2.4.0-0kali1 amd64 [upgradable from: 2.3.3-0kali1]
file/kali-rolling 1:5.41-2 amd64 [upgradable from: 1:5.39-3]
firebird3.0-common-doc/kali-rolling,kali-rolling 3.0.8.33535.ds4-1 all [upgradable from: 3.0.7.33374.ds4-3]
firebird3.0-common/kali-rolling,kali-rolling 3.0.8.33535.ds4-1 all [upgradable from: 3.0.7.33374.ds4-3]
firebird3.0-server-core/kali-rolling 3.0.8.33535.ds4-1 amd64 [upgradable from: 3.0.7.33374.ds4-2]
forensic-artifacts/kali-rolling,kali-rolling 20211012-1 all [upgradable from: 20201106-1]
gcc-10-base/kali-rolling 10.3.0-12 amd64 [upgradable from: 10.3.0-11]
gcc-10/kali-rolling 10.3.0-12 amd64 [upgradable from: 10.3.0-11]
gcc-11-base/kali-rolling 11.2.0-10 amd64 [upgradable from: 11.2.0-9]
gdal-data/kali-rolling,kali-rolling 3.3.3+dfsg-1 all [upgradable from: 3.3.2+dfsg-2]
gir1.2-atspi-2.0/kali-rolling 2.42.0-2 amd64 [upgradable from: 2.42.0-1]
gir1.2-javascriptcoregtk-4.0/kali-rolling 2.34.1-1 amd64 [upgradable from: 2.34.0-1]
gir1.2-soup-2.4/kali-rolling 2.74.1-1 amd64 [upgradable from: 2.74.0-2]
gir1.2-vte-2.91/kali-rolling 0.66.1-1 amd64 [upgradable from: 0.64.2-3]
gnome-desktop3-data/kali-rolling,kali-rolling 41.1-1 all [upgradable from: 41.0-1]
gnuradio-dev/kali-rolling 3.8.2.0-15 amd64 [upgradable from: 3.8.2.0-14]
gnuradio/kali-rolling 3.8.2.0-15 amd64 [upgradable from: 3.8.2.0-14]
golang-src/kali-rolling,kali-rolling 2:1.17~1 amd64 [upgradable from: 2:1.16~1]
gqrx-sdr/kali-rolling 2.14.4-1+b1 amd64 [upgradable from: 2.14.4-1]
gr-osmosdr/kali-rolling 0.2.2-1+b6 amd64 [upgradable from: 0.2.2-1+b5]
greenbone-security-assistant-common/kali-rolling,kali-rolling 21.4.3-0kali1 all [upgradable from: 21.4.2-1]
gsettings-desktop-schemas/kali-rolling,kali-rolling 41.0-2 all [upgradable from: 41.0-1]
gstreamer1.0-plugins-good/kali-rolling 1.18.5-1+b1 amd64 [upgradable from: 1.18.5-1]
gvm/kali-rolling,kali-rolling 21.4.3~0kali1 all [upgradable from: 21.4.2.0]
gvmd-common/kali-rolling,kali-rolling 21.4.4-0kali2 all [upgradable from: 21.4.3-1]
gvmd/kali-rolling 21.4.4-0kali2 amd64 [upgradable from: 21.4.3-1]
hcxdumptool/kali-rolling 6.2.4-1 amd64 [upgradable from: 6.0.5-2]
hcxtools/kali-rolling 6.2.4-2 amd64 [upgradable from: 6.0.2-1+b1]
htshells/kali-rolling,kali-rolling 0.1~git20131205-1kali2 all [upgradable from: 0.1~git20131205-1kali1]
hydra-gtk/kali-rolling 9.2-1 amd64 [upgradable from: 9.1-1+b2]
hydra/kali-rolling 9.2-1 amd64 [upgradable from: 9.1-1+b2]
intel-media-va-driver/kali-rolling 21.4.1+dfsg1-1 amd64 [upgradable from: 21.3.4+dfsg1-1]
iproute2/kali-rolling 5.15.0-1 amd64 [upgradable from: 5.14.0-1]
iw/kali-rolling 5.16-1 amd64 [upgradable from: 5.9-3]
jd-gui/kali-rolling,kali-rolling 1.6.6-0kali1 all [upgradable from: 1.6.3-0kali1]
joplin/kali-rolling 2.6.2-0kali2 amd64 [upgradable from: 2.2.5-0kali2]
jupyter-core/kali-rolling,kali-rolling 4.9.1-1 all [upgradable from: 4.8.0-1]
kali-defaults-desktop/kali-rolling,kali-rolling 2021.4.5 all [upgradable from: 2021.4.2]
kali-defaults/kali-rolling,kali-rolling 2021.4.5 all [upgradable from: 2021.4.2]
kali-desktop-base/kali-rolling,kali-rolling 2021.4.2 all [upgradable from: 2021.4.1]
kali-legacy-wallpapers/kali-rolling,kali-rolling 2021.4.0 all [upgradable from: 2021.2.1]
kali-linux-arm/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-linux-core/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-linux-default/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-linux-headless/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-themes-common/kali-rolling,kali-rolling 2021.4.2 all [upgradable from: 2021.4.1]
kali-tools-802-11/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-tools-bluetooth/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-tools-gpu/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-tools-rfid/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-tools-sdr/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-tools-top10/kali-rolling 2021.4.6 amd64 [upgradable from: 2021.4.3]
kali-undercover/kali-rolling,kali-rolling 2021.4.0 all [upgradable from: 2021.1.2]
kali-wallpapers-2020.4/kali-rolling,kali-rolling 2021.4.0 all [upgradable from: 2021.2.1]
kali-wallpapers-2021.4/kali-rolling,kali-rolling 2021.4.0 all [upgradable from: 2021.2.1]
kali-wallpapers-legacy/kali-rolling,kali-rolling 2021.4.0 all [upgradable from: 2021.2.1]
kded5/kali-rolling 5.88.0-1 amd64 [upgradable from: 5.86.0-1]
kpackagetool5/kali-rolling 5.88.0-1 amd64 [upgradable from: 5.86.0-1]
kwayland-data/kali-rolling,kali-rolling 4:5.88.0-1 all [upgradable from: 4:5.86.0-1]
libaio1/kali-rolling 0.3.112-13 amd64 [upgradable from: 0.3.112-11]
libairspy0/kali-rolling 1.0.10-2 amd64 [upgradable from: 1.0.9-4]
libapache2-mod-php7.4/kali-rolling 7.4.21-1+deb11u1+b2 amd64 [upgradable from: 7.4.21-1+deb11u1+b1]
libapparmor1/kali-rolling 3.0.3-6 amd64 [upgradable from: 3.0.3-4]
libapt-pkg6.0/kali-rolling 2.3.11 amd64 [upgradable from: 2.3.9]
libatspi2.0-0/kali-rolling 2.42.0-2 amd64 [upgradable from: 2.42.0-1]
libaudit1/kali-rolling 1:3.0.6-1+b1 amd64 [upgradable from: 1:3.0.6-1]
libavcodec58/kali-rolling 7:4.4.1-1+b1 amd64 [upgradable from: 7:4.4-6+b2]
libavfilter7/kali-rolling 7:4.4.1-1+b1 amd64 [upgradable from: 7:4.4-6+b2]
libavformat58/kali-rolling 7:4.4.1-1+b1 amd64 [upgradable from: 7:4.4-6+b2]
libavutil56/kali-rolling 7:4.4.1-1+b1 amd64 [upgradable from: 7:4.4-6+b2]
libb-keywords-perl/kali-rolling,kali-rolling 1.23-1 all [upgradable from: 1.22-1]
libbcmail-java/kali-rolling,kali-rolling 1.68-5 all [upgradable from: 1.68-4]
libbcpkix-java/kali-rolling,kali-rolling 1.68-5 all [upgradable from: 1.68-4]
libbcprov-java/kali-rolling,kali-rolling 1.68-5 all [upgradable from: 1.68-4]
libblkid1/kali-rolling 2.37.2-4 amd64 [upgradable from: 2.37.2-3]
libboost-atomic1.74-dev/kali-rolling 1.74.0-13 amd64 [upgradable from: 1.74.0-9]
libboost-atomic1.74.0/kali-rolling 1.74.0-13 amd64 [upgradable from: 1.74.0-9]
libboost-chrono1.74-dev/kali-rolling 1.74.0-13 amd64 [upgradable from: 1.74.0-9]
libboost-chrono1.74.0/kali-rolling 1.74.0-13 amd64 [upgradable from: 1.74.0-9]
libboost-date-time1.74-dev/kali-rolling 1.74.0-13 amd64 [upgradable from: 1.74.0-9]
1
roaima 4 Дек 2021 в 17:52
Ты не задал вопрос
 – 
jsotola
3 Дек 2021 в 19:04
Я добавил один сейчас
 – 
Strategist
3 Дек 2021 в 23:53
Вы добавили другой репозиторий пакетов? Если да, сообщите нам в своем вопросе
 – 
roaima
4 Дек 2021 в 10:51
Использование apt install kali-linux-default выводит тот же вывод, когда я пытаюсь установить что-либо: Огромный список отсутствующих зависимостей нескольких программ.
 – 
Strategist
4 Дек 2021 в 11:55
3 репозитория: repo.steampowered.com/steam, repo.skype.com/deb и kali.download/kali. Он также выводит, что 568 пакетов можно обновить.
 – 
Strategist
4 Дек 2021 в 13:56

2 ответа

Похоже, вы удалили python3 и ruby, и теперь ваша среда рабочего стола и все остальное, зависящее от любого из этих двух пакетов, не работает.

  1. Откройте текстовую виртуальную консоль, нажав сочетание клавиш Ctrl + Alt + F3.

  2. В командной строке login: введите свое имя пользователя и нажмите Enter .

  3. В командной строке Password: введите свой пароль пользователя и нажмите Enter .

  4. Переустановите версию Python 3 по умолчанию и версию ruby ​​по умолчанию, выполнив следующую команду:

    sudo apt install python3-all ruby
    
  5. У вас была установлена ​​среда рабочего стола Kali Linux «по умолчанию» до того, как вы удалили пакеты, которые были зависимостями от среды рабочего стола по умолчанию. Переустановите среду рабочего стола Kali Linux по умолчанию.

    sudo apt update
    sudo apt install -y kali-linux-default
    
  6. Выйдите из виртуальной консоли и вернитесь в среду рабочего стола, нажав сочетание клавиш Ctrl+Alt+F2, чтобы выйти из виртуальной консоли.

2
karel 4 Дек 2021 в 17:10
Если вы получаете ошибки управления пакетами при попытке запустить sudo apt install -y kali-linux-default, вместо этого запустите sudo apt install -y kali-linux-core, чтобы установить только базовую систему Kali Linux. Затем задайте новый вопрос о том, как заставить sudo apt install -y kali-linux-default успешно работать, не вызывая ошибок управления пакетами.
 – 
karel
4 Дек 2021 в 17:23

Это способ сделать это в Ubuntu, но вы можете адаптировать его к своей проблеме.

Я подытожу здесь, чтобы предотвратить гниение ссылок:

Загрузитесь с LiveCD (LiveUSB). Войдите в терминал:

sudo mount /dev/sda1 /mnt

Здесь мы предполагаем, что у вас есть корневой каталог на /dev/sda1

sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys 

Это подготовит вас к следующему делу, которое вы собираетесь сделать. Это важно, потому что /dev, /proc и /sys являются специальными каталогами, файлы, которые они содержат, генерируются виртуально и представляют внутреннюю работу вашей системы.

sudo chroot /mnt 

Это сделает корневой каталог для этого сеанса терминала тем, что вы смонтировали выше.

 sudo apt update
 sudo apt upgrade

В настоящее время. Если это не сработает, то это может быть более серьезная проблема. И судя по тому, что вы описали, это как раз может быть один. Вероятно, вам нужно будет сделать что-то вроде:

 sudo dpkg -i package.deb

К сожалению, у меня нет списка пакетов, необходимых для работы GUI на Kali, и я очень надеюсь, что вы не сломали сам dpkg. Вы также не уничтожили X.org.

1
v010dya 4 Дек 2021 в 10:33
1
Поскольку система OP загружается, я не понимаю, зачем вам что-то нужно, включая chroot. (Возможно, вам не нужно использовать `sudo| ни для одной из команд, так как, скорее всего, Live CD уже работает от имени пользователя root.)
 – 
roaima
4 Дек 2021 в 10:49
Насколько я помню, у LiveCD нет пароля на root, но пользователь не root. Однако, если у пользователя нет доступа к Интернету для загрузки пакетов, ему все равно может потребоваться загрузка с чего-то вроде LiveCD. Трудно понять, я просто пытался быть полезным.
 – 
v010dya
4 Дек 2021 в 10:53
Хорошо, спасибо за это. Я использовал только автономные системы, такие как RescueCD, который определенно работает с правами root.
 – 
roaima
4 Дек 2021 в 10:57
Я могу нормально загрузиться и получить доступ ко всем своим файлам, а также могу подключиться к Интернету с помощью терминала, но каждый раз, когда я пытаюсь загрузить что-либо, вывод начинается с «Следующие пакеты имеют неудовлетворенные зависимости:», и он выводит длинный список имена пакетов и их зависимости, которые не установлены.
 – 
Strategist
4 Дек 2021 в 11:59
Я знаю, что это сложно сделать с не полностью работающей машины, но, пожалуйста, сохраните этот список в текстовом файле где-нибудь на USB или что-то в этом роде, чтобы вы могли добавить его к своему вопросу здесь. Без него мы вынуждены гадать.
 – 
v010dya
4 Дек 2021 в 12:47