Я пытаюсь установить snap на свой компьютер с rhel 8.4, и он выдает следующую ошибку.

Error: 
 Problem: package snapd-2.54.1-1.el8.x86_64 requires snapd-selinux = 2.54.1-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides selinux-policy-base >= 3.14.3-80.el8_5.2 needed by snapd-selinux-2.54.1-1.el8.noarch

У меня есть selinux-policy-3.14.3-67.el8_4.2 на моей машине.

0
pzkpfw 9 Янв 2022 в 17:18
Добавьте вывод subscription-manager repos --list к вопросу.
 – 
Nasir Riley
9 Янв 2022 в 17:19
Я получаю «В этой системе нет репозиториев, доступных по подписке».
 – 
Rupam Bhattacharjee
9 Янв 2022 в 20:03
Добавьте его к вопросу, а также вывод subscription-manager status. Не пишите это в комментариях.
 – 
Nasir Riley
9 Янв 2022 в 22:37

1 ответ

Основная проблема описана ошибкой:

ничего не дает selinux-policy-base >= 3.14.3-80.el8_5.2

Поскольку ни один из ваших репозиториев не может предоставить эту зависимость, установка не может быть продолжена.

Похоже, подобные проблемы случались и раньше, и в этом случае репозитории RHEL просто отставали. . Вы можете попробовать sudo dnf upgrade --refresh еще раз и посмотреть, доступен ли пакет. Если нет, я не думаю, что есть хорошее решение этой проблемы без включения сторонних репозиториев (что, вероятно, не очень хорошая идея).

Как вы можете видеть здесь: https://pkgs.org/download/selinux-policy-base< /а>

...версия 3.14.3-80 в настоящее время доступна как для AlmaLinux, так и для Rocky Linux, которые бинарно совместимы с RHEL. Кажется странным, что у RHEL не будет пакета, учитывая, что они оба выше по течению.

Возможно, вы используете спутниковый репозиторий, который устарел? Я думаю, вы должны исследовать свои репозитории как источник этой ошибки.

0
pzkpfw 9 Янв 2022 в 17:15