Когда я попытался установить rpm в свой виртуальный ящик CentOS7.8 с помощью этой команды:

rpm -ivh cpp-4.8.5-44.el7.x86_64.rpm kernel-headers-3.10.0-1160.el7.x86_64.rpm glibc-headers-2.17-317.el7.x86_64.rpm glibc-devel-2.17-317.el7.i686.rpm glibc-devel-2.17-317.el7.x86_64.rpm

Я получил эту ошибку.

error: Failed dependencies:
        glibc = 2.17-317.el7 is needed by glibc-headers-2.17-317.el7.x86_64
        glibc = 2.17-317.el7 is needed by glibc-devel-2.17-317.el7.i686
        glibc = 2.17-317.el7 is needed by glibc-devel-2.17-317.el7.x86_64

Может ли кто-нибудь сказать мне, что это значит и как это решить?

0
AdminBee 15 Ноя 2021 в 16:19

1 ответ

Вы используете yum/dnf для этого. Похоже, вы где-то получили несколько пакетов, но ваша базовая система не обновлена.

(В качестве быстрого обходного пути загрузите также glibc-2.17-317.el7.i686.rpm и glibc-2.17-317.el7.x86_64.rpm и сначала rpm -Uvh им).

2
Artem S. Tashkinov 15 Ноя 2021 в 18:00