У меня двойная загрузка Ubuntu и Windows, и у меня 2 SSD. Первый, 1 ТБ, предназначен для Windows, а другой, 500 ГБ, для Ubuntu. Я настроил его для загрузки в Grub, но каждый раз, когда Windows обновлялась или что-то в этом роде, он, казалось, выбрасывал это, и система просто загружалась прямо в Windows. Поэтому я просто нажимал F11 при загрузке, чтобы получить доступ к параметрам, а затем выбирал Ubuntu, когда мне это нужно, что приводит меня к личинке, а затем я фактически выбираю ее. Все это работает, но немного больно. Есть ли более простой способ настроить это? Я не хочу заново настраивать каждый раз при обновлении Windows. Подойдет даже простое использование меню загрузки BIOS по умолчанию при каждом запуске, но я не вижу способа установить это в BIOS (MSI B450 MB).

Если это поможет:

$  efibootmgr -v
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0000,0001,0002
Boot0000* Windows Boot Manager  HD(2,GPT,c6a1dba9-5c97-46d3-b98c-a9bcb9f5184d,0xfa000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* ubuntu    HD(1,GPT,1cb82576-8a01-4836-a909-440920fe0ea4,0x800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* ubuntu    HD(2,GPT,c6a1dba9-5c97-46d3-b98c-a9bcb9f5184d,0xfa000,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)..BO

Что странно, так это то, что второй вариант Ubuntu указывает на диск емкостью 1 ТБ (согласно имени, которое появляется в меню загрузки), на котором нет установки Ubuntu. Но вроде работает, и запускает установку на диск 500гб. Эту опцию я удалял пару раз, но каждый раз, когда Windows возится с ней, она снова добавляет эту опцию.

Таким образом, нажатие Boot0001 или Boot0002 приводит меня к grub, меню которого:

$  awk -F\' '/menuentry / {print $2}' /boot/grub/grub.cfg 
Ubuntu
Ubuntu, with Linux 5.4.0-70-generic
Ubuntu, with Linux 5.4.0-70-generic (recovery mode)
Ubuntu, with Linux 5.4.0-67-generic
Ubuntu, with Linux 5.4.0-67-generic (recovery mode)
Windows Boot Manager (on /dev/sda2)
UEFI Firmware Settings
0
steprobe 1 Апр 2021 в 17:49
С UEFI как обновления Windows, так и обновления Ubuntu/grub изменят порядок загрузки UEFI, чтобы эта система была первой. Windows и несколько более новых систем Ubuntu также могут обновлять UEFI, который сбрасывает многие настройки UEFI до значений по умолчанию, которые также могут потребовать повторной настройки. А обновления Windows могут снова включить быстрый запуск, не позволяя grub загружать Windows. Это просто то, чем вы должны управлять. Вы всегда должны иметь возможность загрузить любую систему из загрузочного меню UEFI. А потом можно сбросить порядок загрузки или зайти в UEFI и обновить настройки.
 – 
oldfred
1 Апр 2021 в 22:04

1 ответ

Измените порядок загрузки с помощью efibootmgr, чтобы Ubuntu был первым:

efibootmgr -o 0001,0000
1
psusi 1 Апр 2021 в 17:59
Когда я запускаю это, он выглядит хорошо (порядок загрузки 0001, 0000), но когда я перезагружаюсь, он все еще переходит в Windows, и в следующий раз, когда я захожу в Ubuntu, я вижу, что порядок загрузки был изменен на 0000, 0001, 0002
 – 
steprobe
3 Апр 2021 в 17:18