Я новичок в Arch, поэтому любая помощь по этому вопросу очень ценится. Я пытался установить yaourt на manjaro, но это сообщение об ошибке, которое я получаю.

[manjaro@manjaro-pc ~]$ sudo pacman -S yaourt
error: target not found: yaourt
3
balon 14 Ноя 2019 в 20:50
Мои извинения за ошибку. Я использую новую установку Manjaro. Я начал с обновления системы и обновления (которое у меня есть сообщения об ошибках); ошибка: обнаружены неразрешимые конфликты пакетов ошибка: не удалось подготовить транзакцию (конфликтующие зависимости) :: manjaro-gnome-settings-18.0 и manjaro-gnome-settings-17.0 конфликтуют
 – 
Reubenite King
14 Ноя 2019 в 19:04
Относительно ваших конфликтующих зависимостей см.: forum.manjaro.org/t/…
 – 
SYN
14 Ноя 2019 в 19:33
По поводу yaourt: он медленно умирает. Вместо этого вы можете заглянуть в packer
 – 
SYN
14 Ноя 2019 в 19:34
Используйте git clone, затем makepkg
 – 
JoKeR
15 Ноя 2019 в 01:27

1 ответ

Лучший ответ

Yaourt был удален с официальных серверов Arch Linux из-за серьезных проблем с безопасностью. Умри.

Его больше нельзя или не следует скачивать из официальных репозиториев, и делать это другими способами небезопасно.

Я рекомендую перейти на более безопасные альтернативы для пакетов AUR, например aurman.

Ссылки по интересам:

Обновление с установкой aurman:

Вы можете установить aurman с помощью следующего скрипта:

#!/bin/bash

cd /tmp
gpg --recv-key 465022E743D71E39
git clone https://aur.archlinux.org/aurman.git
cd aurman
makepkg -si
sudo sed -i '/^#Color/s/^#//' /etc/pacman.conf
aurman -Syu

Использование aurman проще, чем yaourt, и очень похоже на pacman.

6
balon 14 Ноя 2019 в 20:07
1
Спасибо за помощь! Закончил установку aurman, пока все работает нормально.
 – 
Reubenite King
16 Ноя 2019 в 08:46
В настоящее время это дает ==> ERROR: One or more PGP signatures could not be verified!
 – 
jbarlow
12 Фев 2020 в 11:43