При запуске виртуальной машины в VMware (хост Ubuntu 16.04) как гостевая система (на данный момент Windows 10), так и хост-система регулярно перестают отвечать на запросы в течение нескольких секунд, например. при запуске Atom или Visual Studio на гостевой виртуальной машине.

Отчеты об использовании ОЗУ выглядят нормально (всего 16 ГБ, 6,5 ГБ используются виртуальной машиной как «общая память», несколько ГБ свободно), но пока система не отвечает, задачи ввода-вывода либо приостановлены, либо очень медленны, например копирование/вставка текста. занимает несколько секунд.

Изменение настроек (настройки виртуализации, ОЗУ ВМ и т. д.) в VMware не имеет никакого эффекта.

9
Simon A. Eugster 30 Июл 2018 в 13:29
Несмотря на то, что вы нашли решение, я удивлен, что вас устраивает 5 ГБ ОЗУ, используемое для вашей виртуальной машины, поскольку, исходя из моего опыта, W10 выделяет 5+ ГБ сразу при запуске, а VS 2017 занимает около 500 МБ, поэтому 5,5 ГБ используется под W10 на физическом хосте с 16 ГБ ОЗУ — это нормально. Добавление AV и других второстепенных корпоративных вещей увеличивает начальное выделение ОЗУ на моей текущей машине до 9,5 ГБ сразу после нового запуска.
 – 
ajeh
27 Июл 2018 в 20:28
Ты прав. В настоящее время виртуальная машина настроена на 6,5 ГБ. В free -h память, используемая VMware, не отображается в разделе «используемая память», а только в разделе «общая» (например, в настоящее время отображается 2 ГБ использованных и 3 ГБ свободных). Обновлю вопрос, чтобы уточнить это :)
 – 
Simon A. Eugster
30 Июл 2018 в 09:55

7 ответов

Я оставлю этот ответ здесь, если он может помочь кому-то еще.

Я сталкивался с частыми зависаниями и зависаниями как на хосте (Ubuntu 19), так и на гостевой системе (Centos 7) при использовании VMware. Не знаю в чем проблема и решения не нашел ни на одном форуме. Я использую Dell XPS 9570.

Зависания прекратились, когда я отключил параметры «Движок виртуализации». Перейдите в «Настройки виртуальной машины» > «Процессоры» и убедитесь, что в «Механизме виртуализации» не установлен флажок.

enter image description here

5
Paulo Tomé 11 Янв 2020 в 22:21

Когда я отключил блокировку записи устройства cahce(vmware), проблема исчезла
введите здесь описание изображения

0
user164485 6 Апр 2021 в 17:47
Это повлияет на производительность
 – 
David Kariuki
24 Апр 2021 в 01:12
Сколько воздействий? возможно, вы могли бы получить лучшую производительность.
 – 
user164485
25 Апр 2021 в 08:57

У меня была похожая проблема в Ubuntu 18.04 на док-станции Dell XPS 15 9670 и TB16 (регулярно временные зависания (1-5 с), запуск Win10 вызывает воспроизводимые сбои). После действий ниже все проблемы ушли:

  • Обновление до рабочей станции 15.5.5
  • Отключите док-станцию ​​и USB-устройства: похоже, в USB-подсистеме Linux довольно много проблем из-за плохих отраслевых спецификаций и т. д. (Грег К.Х. ответил на мой пост в https://www.spinics.net/lists/linux-usb/msg182825.html). Старая док-станция Dell D3100 воспроизводимо приводила к сбою ядра Linux. Попробуйте без док-станции и USB-устройств, прежде чем выполнять какие-либо другие пункты, описанные ниже.
  • Уменьшить «подкачку» Ubuntu (временно): sysctl -w vm.swappiness=10
  • Отключите огромную страницу, как указано выше (временно): echo never > /sys/kernel/mm/transparent_hugepage/defrag; echo 0 > /sys/kernel/mm/transparent_hugepage/khugepaged/defrag; эхо никогда > /sys/kernel/mm/transparent_hugepage/enabled
  • Уменьшите объем памяти гостевых ВМ до 3 ГБ.
  • Зарезервируйте 8G RAM для хост-ОС, как указано выше.
  • Отключите 3D-ускорение в Gnome и в настройках виртуальной машины.
  • Используйте Wayland, так что вместо полного замораживания (перезагрузки) вы получите новый экран входа в систему (перезапуск Wayland?)

Я до сих пор не уверен, кто из них действительно прибил это, но теперь я в порядке наконец.

2
fraber 30 Май 2020 в 16:48

Вот исправление, которое сработало для меня: https://gist.github.com/2E0PGS/2560d054819843d1e6da76ae57378989

1
Gene Olson 5 Дек 2021 в 19:34
Возможно, было бы неплохо отредактировать и, если возможно, включить соответствующие части ссылки в свой ответ. В противном случае это ответ только по ссылке, и если ссылка исчезнет, ​​ваш ответ не будет таким полезным.
 – 
Greenonline
5 Дек 2021 в 19:45
  1. Отключить khugepaged дефрагментацию:

    echo never | sudo tee /sys/kernel/mm/transparent_hugepage/defrag
    echo 0 | sudo tee /sys/kernel/mm/transparent_hugepage/khugepaged/defrag
    

    Вы также можете сделать это, добавив запись transparent_hugepage=never в свой grub, а затем введите update-grub на своем терминале, чтобы обновить grub.


  1. Отключите механизм виртуализации.
  2. Убедитесь, что объем оперативной памяти не превышает оперативной памяти хоста. например, если оперативная память вашего компьютера составляет 8 ГБ, дайте вашей виртуальной машине менее 4.
  3. Установите разумное количество ядер процессора.
  4. Обновите, что вы VMware, если вы используете старую версию.
  5. Иногда переустановка vmware решает проблему, если все вышеперечисленное не работает.
0
David Kariuki 4 Май 2021 в 16:20

Решение состоит в том, чтобы отключить дефрагментацию khugepaged:

echo never | sudo tee /sys/kernel/mm/transparent_hugepage/defrag
echo 0 | sudo tee /sys/kernel/mm/transparent_hugepage/khugepaged/defrag

См. этот ответ на вопрос Arch Linux перестает отвечать на запросы khugepaged.

Кроме того, вероятно, было бы неплохо ограничить объем оперативной памяти, которую VMware может использовать для запуска виртуальных машин, чтобы зарезервировать часть для хост-системы (Edit > Preferences).

VMware settings for reserved memory


Примечание. Я повторно публикую этот ответ под этим вопросом, потому что ответ очень сложно найти — мне буквально потребовались годы.

9
Simon A. Eugster 27 Июл 2018 в 19:35
3
В качестве альтернативы вы можете добавить параметры ядра в grub transparent_hugepage=never
 – 
Rui F Ribeiro
27 Июл 2018 в 19:48

Мне ничего из вышеперечисленного не помогло, также не помогло отключение поддержки 3D.

Вместо этого, казалось, помогло установить параметр питания «Отключить жесткий диск через» (в «Параметры электропитания»> «Изменить дополнительные параметры питания») на «0» (минуты), чтобы отключить эту функцию.

Это также, похоже, связано с тем фактом, что проблема обычно возникала только через некоторое время, когда работающая виртуальная машина не использовалась (что затем давало Windows достаточно времени, чтобы запустить этот параметр и попытаться выключить / включить «диск» (фактически SSD в хост-система)).

4
frog.ca 12 Май 2020 в 18:05