РЕДАКТИРОВАТЬ: Обновления ниже, декорации, похоже, значительно изменились. У меня Ubuntu 20.04, и я установил Python 3.10 вручную. В системе уже есть Python 2, и это то, что я получу, если просто выполню python в командной строке, а не python3. Однако у меня есть только версия pip, специфичная дл....
askubuntu 10 Янв 2022 в 06:18
Я пытаюсь создать виртуальную среду, которая может получить доступ к контактам GPIO. Для этого мне нужен доступ к RPi.GPIO в среде. Я не могу установить это в виртуальную среду. Мне удалось заставить его работать, позволив среде иметь доступ к системным пакетам, но я бы хотел этого избежать. Я ус....
raspberrypi 25 Дек 2021 в 17:17
Пип модуля импорта не работает: import pip Traceback (most recent call last): File "C:\OSGeo4W\apps\Python39\lib\code.py", line 90, in runcode exec(code, self.locals) File "<input>", line 1, in <module> File "C:\OSGeo4W/apps/qgis/./python\qgis\utils.py", line 888, in _import mod = _bui....
Нет опыта работы с Freebsd, но мне нужно написать и запустить скрипт. Не могу установить python-ldap или другую библиотеку. Ошибка: /usr/local/bin/python3.7 -m pip install python-ldap ld-elf.so.1: /lib/libc.so.7: version FBSD_1.6 required by /usr/local/lib/libpython3.7m.so.1.0 not found Эта библио....
unix 30 Ноя 2021 в 13:56
У меня возникли проблемы с установкой ноутбука Jupyter на мою виртуальную машину Linux. Каждый раз, когда я использую что-либо с pip или pip3 в нем (например, sudo python3 -m pip install jupyter), я получаю эту ошибку (или очень похожую ошибку): Traceback (most recent call last): File "/home/user....
unix 19 Окт 2021 в 09:51
Я на Debian 11, который поставляется с python3.9. Но мне это не нужно, мне нужен python3.7. Итак, я установил pythonn3.7.9 и обновил альтернативы. Проблема в том, что когда я переключаю версию Python на 3.7.9, я не могу ничего установить с помощью pip. Я получаю следующую ошибку в команде pip ins....
unix 30 Сен 2021 в 16:21
Если я попытаюсь установить pip для Python 2 с помощью sudo apt-get install python-pip, появится следующее сообщение об ошибке: Package python-pip is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another....
unix 23 Сен 2021 в 22:39
Я новичок в Docker, поэтому не знаю, как интерпретировать причину ошибок. "Poetry — это инструмент для управления зависимостями и создания пакетов в Python. Он позволяет объявлять библиотеки, от которых зависит ваш проект, и он будет управлять ими (устанавливать/обновлять) за вас». pip не работает,....
unix 1 Сен 2021 в 05:42
Контекст Личный контекст: Неопытный пользователь Linux, изучающий Python в надежде применить его для обработки естественного языка в базах данных NoSQL. Почему GNU/Linux: Бюджет у меня небольшой, старое оборудование совсем не сломалось, но не выдерживает нагрузки, которую на него возлагает Windows. ....
Когда я набираю cura в свой терминал, я получаю эту ошибку, и программа не запускается: john@arch-thinkpad ~> cura /usr/lib/python3.9/site-packages/UM/PluginRegistry.py:4: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses i....
unix 5 Авг 2021 в 19:21
Я пытаюсь скомпилировать скрипт с помощью pyarmor, но все время получаю сообщение об ошибке. ┌──(kali㉿kali)-[~/Desktop] └─$ pyarmor-webui pyarmor-webui: command not found Я установил его с помощью pip3 install pya....
unix 11 Июл 2021 в 16:40
Пытаясь сделать свой .zshrc аккуратнее, я наткнулся на следующую проблему/вопрос: «Как я могу запустить вывод другой команды?». Хотя я уверен, что это простая проблема, я просто не понимаю, что я делаю неправильно. Я хочу добавить pip-completion в свою конфигурацию. Для этого мне нужно добавить в....
unix 24 Июн 2021 в 21:02
Здравствуйте, я БОЛЬШОЙ новичок в Linux, который использует Debian Stretch. Я получаю сообщения об ошибках, когда пытаюсь установить или удалить пакеты. Это ошибка, которую я получаю, когда пытаюсь установить пакеты с помощью pip3: dsal3389@Dsal3389:~$ pip3 install django Could not find platform i....
unix 21 Июн 2021 в 12:31
$ pip install impacket Requirement already satisfied: impacket in /home/kali/.local/li....
unix 18 Июн 2021 в 12:58
Мне нужно запустить некоторый код Python на удаленной машине, которая имеет довольно тяжелые зависимости. В моем домашнем каталоге (.../home/d/my-name) очень мало места на диске, поэтому я обычно использую другой каталог (/local/my-name), в котором в качестве моего "эффективного" домашнего каталога....
unix 22 Май 2021 в 07:09
Я пытаюсь изменить pip (версия 9), чтобы получать пакеты python исключительно с моего сервера Artifactory вместо pypi. Мой файл /etc/pip.conf имеет только конфигурации для попадания в мой репозиторий Artifactory, однако при анализе сетевых пакетов я вижу, что все еще получаю пакеты с pypi.org Выполн....
unix 17 Май 2021 в 16:19
Когда я пытаюсь установить это, я получаю эту ошибку; Каково решение? ubuntu@ip-xxx-xxx-xxx-xxx:~/URLuploader-With-Hotstar$ pip3 install -r requirements.txt Traceback (most recent call last): File "/usr/bin/pip3", line 9, in <module> from pip import main File "/usr/lib/python3/dist-packages....
unix 25 Апр 2021 в 17:50
Я пытаюсь выполнить pip install tensorflow на своей Raspberry, но получаю ошибку Errno 28 "На устройстве не осталось места". Я читал из нескольких источников, что это означает, что папка, используемая pip install во время распаковки, слишком мала, но я не знаю, как узнать, потому ли это, что она де....
unix 16 Апр 2021 в 16:40
У меня есть python2 и python3. Когда я бегу pip --version pip 21.0.1 из /home/istiak/.local/lib/python3.9/site-packages/pip (python 3.9) └─$ python2 --version Python 2.7.18 У меня есть код Python2. Что написано странным образом ~ я думаю, bash. Вот репозиторий git. Итак, я хочу запус....
unix 11 Апр 2021 в 18:43
Установлен требуемый модуль lxml, но при импорте возникают ошибки ImportError: No module named lxml Откуда я знаю Из какого места рассматриваются модули Python? Какая версия Python и pip используются или установлены? Пожалуйста, помогите мне разобраться и решить эту проблему. uname -a Linux machine-....
unix 3 Апр 2021 в 16:05
Я начал изучать Python, но мне трудно понять Linux. uname -a Linux machine-name 4.4.0-31-generic #50~14.04.1-Ubuntu SMP Wed Jul 13 01:07:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux which python /usr/local/bin/python which pip /usr/local/bin/pip pip --version /usr/local/lib/python2.7/dist-packages/....
unix 30 Мар 2021 в 18:19
Я устанавливаю python3-pip~~.rpm на RHEL7.6, но получаю сообщение об ошибке /usr/bin/python3 is needed by python3-pip~~~.noarch python(abi) = 3.6 is needed by python3 ~~~.noarch Система поставлялась с предустановленным Python 2.7.5, и я вручную установил Python 3.9.0 из официального файла tar.gz py....
unix 30 Мар 2021 в 06:50
Установка файла python3-setuptools-39.2.0-10.el7.noarch.rpm с помощью команды sudo rpm -i на Red Hat 7.6 без доступа в Интернет привела к ошибке с сообщениями /usr/bin/python3 is needed by python3-setuptools~~ python(abi) = 3.6 is needed by python3-setuptools~~ Система RHEL7.6 поставлялась с Python....
unix 30 Мар 2021 в 02:17
Я пытаюсь установить KIWI на свой RaspBerry Pi. Когда я пытаюсь pip install kiwi Я получаю ошибку связывания, с /usr/lib64/gcc/aarch64-suse-linux/10/../../../../aarch64-suse-linux/bin/ld: cannot find -lpython3.6m collect2: error: ld returned 1 exit status error: command 'gcc' failed with exit stat....
unix 4 Мар 2021 в 11:49
Я столкнулся с запутанной ситуацией. Официальная последняя полностью поддерживаемая версия Python — 3.9, и хотя она доступна в FreeBSD pkg, pip-3.9 — нет, и она понадобится мне в будущем, когда Python 3.7 достигнет EOL. Короче говоря: Python 3.7: доступен, Python 3.9: доступен, пункт 3.7: доступен,....
unix 2 Мар 2021 в 05:28